What should I know about breast cancer? I want to know
Cart 0

Upgrade Your Browser For Hassle-Free Shopping!

Ray

On 30 April 2018 from 1am to 4am (GMT +8), Beautyspot will undergo server maintenance for the preparation of TLS 1.0 disablement. From that time onward, please use browser that support TLS 1.1 only. Else, your may experience payment failure.

If you like to know more about the TLS 1.0 topic, please click HERE but simply put, it is important to disable TLS1.0 and use TLS 1.1 or above so that your payment information is secure and not being stolen by the bad guy.

Therefore, please make sure you are using the latest browser as per recommended below: 


In case you are not sure how to check, or you suspected your payment failed because of outdated browser, please contact us so that we can check on the issue.

Happy hassle-free shopping!





Older post